Failed screenshot with customized login screen

Issue

This article describes the cause and solution for screenshot errors resulting from customized login screens.

Environment

  • Datto SIRIS
  • Datto ALTO

Cause

Customized login screens or additional prompts such as legal notices that appear before the login page can result in screenshot verification failures. Because of the additional image processing involved, some elements of customized login screens can affect the image processing during the screenshot verification, including:

  • Complex rasterized background images.
  • Complex fonts.
  • Windows shell modification.

Those potential changes can cause a bootable point to show as a failed screenshot.

Resolution

Use the default Windows theme or manually configure the Windows machine so the login screen appears to be unmodified, then take a new backup.

If the screenshot continues to show as failed with the default login screen, contact Datto Technical Support to confirm screenshot verification configuration and verify that the recovery point is bootable.

Due to the variables stated above, the ability to resolve screenshot errors caused by customized login screens may be limited and results will vary. If the login screen cannot be updated to the default, screenshots may need to be manually checked regularly to confirm the bootability of the backup points.