Datto Windows Agent - Backups Hung at "Preparing Next Volume"
Issue
When backups are initiated for a system protected with Datto Windows Agent, the backup status remains on the "Preparing Next Volume" step indefinitely.
Environment
- Datto Windows Agent
- Datto SIRIS
- Datto ALTO
Cause
The user running the Datto services does not have sufficient permissions to access a required VSS registry key.
Resolution
- Open the Windows Event Viewer of the server that is having issues.
- Open the Application Event Log.
- Confirm that this error message is shown:
Source: VSS
Event ID: 8193
Message: Volume Shadow Copy Service error: Unexpected error calling routine RegOpenKeyExW(-2147483646,SYSTEM\CurrentControlSet\Services\VSS\Diag,...). hr = 0x80070005, Access is denied.
- In the Details pane of Event Viewer, under In Bytes, confirm the name of the user account that generated the error.
- From the start menu, open the registry editor by typing regedit. Run the program as Administrator.
- Navigate to "Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VSS."
- Right-click the VSS key and click Permissions.
- Select the User name found in the error message. You will see that the user does not have "Full Control" of this registry location.
- In the Allow column, Check the boxes next to Full Control and Read, then click Apply.
- On the Datto Web Interface, navigate to the Protect page and start a backup. It should now succeed.