Screenshots Fail to a Chkdsk or Windows Updating Screen
Issue
Screenshots fail to an image of the chkdsk screen or windows updating screen.
Environment
- Datto ALTO
- Datto SIRIS
Cause
The machine being backed up has a chkdsk scheduled on the next boot or Windows updates require a reboot to finalize.
Resolution
For screenshots showing the chkdsk screen
Check if the system has its dirty bit set:
1. Type CMD
into the Windows search bar, then right-click the command prompt icon and select Run as administrator to open an elevated Windows command prompt.
2. Run the following command at the prompt:fsutil dirty query [drive letter]:
This checks a given volume and returns an output indicating if the volume has its dirty bit set. If so, the output will be output similar to the output below :
Volume - C: is Dirty
3. If the dirty bit is set, a chkdsk must run before normal screenshots will resume. Reboot the machine, open an elevated command prompt and type:chkdsk /r [drive letter]
Check if a chkdsk is scheduled on the agent system:
1. In the Windows command prompt, check if a scheduled chkdsk is pending on the agent system chkntfs 'C:'
If there is a chkdsk pending, the output will be output similar to the output below :
The type of the file system is NTFS. Chkdsk has been scheduled manually to run on next reboot on volume C:
2. Reboot the agent system to run the chkdsk unset the dirty bit on the volume. Afterward, take a new backup. If the issue persists, it may be beneficial to invoke a chkdsk /r against any volumes having issues on the agent system.
For screenshots showing the Windows Update screen
Reboot the machine to finalize the updates and take a new backup.
If you have tried all the steps above and are still having issues, contact Datto Technical Support.
Additional resources
FSUTIL : dirty (external article)
CHKNTFS (external article)
CHKDSK (external article)