Troubleshooting VMDK file not found errors
Topic
This article discusses the following error message and common causes for it.
Critical backup failure: VMDK file not found: /home/agents/vm-vmname/vm.vmdk. Check if VM mount succeeded.
Environment
- Datto SIRIS
- Agentless backups
Description
This error can appear when:
Attempting to pair a system using the agentless backup method.
Attempting a backup of a system protected agentlessly.
Possible Causes

This can be caused by ESXi failing to resolve a VM's address by its hostname, which is the first step in the backup process. The vddk-fuse process then mounts the snapshot from the VMWare environment for network transfer to the Datto device.
Confirm there is an internal DNS entry in the DNS Overrides section of the datto device. This can be accessed by selecting Configure > Networking in the Datto appliance GUI.
Make sure that internal DNS entries appear above the public entries.

Attaching independent disks to the VM may also cause this error. Independent disks are not affected by VMware snapshots, and the VMDK 'file not found' error can occur during pairing.
Remove any independent disks attached to the protected machine, backing up a machine with them is unsupported.

If the datastore or the protected machine's name in VMware contains non-ASCII characters, the pairing process may fail with this error as well.
The protected machine or the hosting datastore would need to be renamed to exclude the non-ASCII characters, to be protected.

If pairing still fails or is unable to resume backups, add the Datto device to your domain.
Test communication to the target VM again. This test confirms if internal DNS troubleshooting is necessary; you should not leave the device on the domain after troubleshooting.