Restore's network share prompts for credentials
Issue
When trying to access a network share hosted by the Datto device, it is prompting for a username and password to access the share. These shares are used for File Restores and Image Exports. They are public shares by default.
Environment
- Datto SIRIS
- Datto ALTO
Cause
When the Datto device has the Secure File Restore and Export feature enabled, it is expected to prompt the user for local credentials prior to granting access.
Resolution
When you see a credential prompt, enter the username and password of an authorized local user account on the Datto device.
To enable or disable the Secure File Restore and Export feature:
Log into the Datto device UI, locally or through the Partner Portal.
Click the Protect tab at the top of the page.
Select Configure Agent Settings for the target agent.
Navigate to Secure File Restore & Export, under Advanced to edit the selection.
The drop-down menu can be used to authorize a user, who will then be able to access the share with their credentials.
NOTE To save this setting, the agent cannot have an active File Restore or Image Export. They will first need to be removed before setting this configuration.
The Secure File Restore and Export feature is disabled by default. If you continue to have problems logging in to your share contact Datto Technical Support.