Backups fail with "Couldn't connect to mercury"
Issue
When you attempt to start a backup for a protected system using the Datto Windows Agent, you receive the error message, "Couldn't connect to mercury://<identifier>.dattolocal.net:3262/iqn.2007-01.net.datto.dev.temp.on-<Datto unit's hostname>.agent<agent's UUID>/0 code: -13 message: resolve: No such host is known."
Environment
- Datto Windows Agent
Cause
Communication between the Datto Windows Agent and the datto device is dependent on the publicly resolvable paths in the above error (relating back to <identifier>.dattolocal.net). If the datto device or the protected machine running the Datto Windows Agent service are unable to resolve the dattolocal.net hostname, the communication will fail.
Resolution
The protected machine and the datto device must be able to resolve these addresses. The two ways to accomplish this are:
Both machines must have a public DNS server as a secondary/tertiary resolution server.
or
The local DNS server needs to be configured with a DNS forwarder to a public DNS for when it is unable to resolve hostnames.
If both machines are able to resolve the host in the backup error given and are still failing with the same error, reach out to datto technical support.