Agent Screenshot Verification Failed
Issue
After completing a screenshot for an agent, an email alert from noreply@datto.com is received which states:
"Agent Screenshot Verification Failed. Screenshot verification failed for [systemname]. This may indicate an issue with the backup itself."
Environment
- Datto Endpoint Backup for PCs
Cause
A protected system, registered to one of your organizations, performed a screenshot verification which resulted in a failed boot of the virtual machine.
This email was sent because the Partner Portal account is subscribed to receive registration alerts. To change alerting settings, visit the Datto Endpoint Backup Status page.
Resolution
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If the notifications report a failure, but the screenshot shows that your virtual machine is booting successfully, proceed to the Contacting Support section of this article.
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If the screenshot verification shows the virtual machine in a failed boot state, observe the full boot sequence of the restore point by virtualizing it in the cloud. Document any unusual behavior that you observe. Then, check the production machine. Many boot failures replicate from issues which are present in the production environment.
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If the screenshot failure shows Windows updates installing, schedule a maintenance window for the production machine, reboot it, and allow its pending Windows updates to install. Then, resume backups, and observe the outcome of the next day's screenshot verification.
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If the screenshot verification email shows a blank or black screen, and the production machine has a screensaver or power saving mode, the behavior may be replicating to the Datto Endpoint Backup virtual machine, resulting in a screenshot with its display turned off. Adjust the display timeout on the production machine to a longer delay than ten minutes, or disable it entirely. Then, take another backup, and observe the results of the following day's screenshot.
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If the screenshot failure shows CHKDSK operations underway, schedule a maintenance window for the production machine, reboot it, and allow the disk operation to run. Then, resume backups, and observe the outcome of the next day's screenshot verification.
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If, during cloud virtualization, you observe any other unusual boot behavior which you can replicate on the production machine, correct the problem in the live environment, resume backups, and observe the outcome of the next day's screenshot verification.
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If the failed screenshot verification does not fall into the above-listed categories, or if you are unable to resolve the issue via the troubleshooting methods described, proceed to the Contacting Support section of this article.
Screenshots will not run if a Windows update is pending. A reboot of the protected machine may be required to resume screenshots on the next backup.
Contacting Support
- Before contacting Datto Technical Support, gather the following information about the screenshot failure:
- Detailed description of the problem
- Detailed description of all troubleshooting attempted
- Screen capture of the failed verification notice which shows the screenshot performed
- Hostname of the impacted system
- Datto Endpoint Backup Agent version and the Agent ID for the affected system
- Agent logs from the affected system
- Attach this information to a Technical Support ticket, and then contact Datto Technical Support for assistance.