Duplicate volume appears after restoring with Image Export
Issue
After restoring an agent using Image Export, you see the warning banner, "The following previously included volumes were not backed up because they were unavailable during the backup process," but the 'missing volume' is a duplicate of an existing volume.
Environment
- Datto SIRIS
- Datto ALTO
Cause
The GUID of a volume has been changed, but the volume letter is still the same. Backups will continue to succeed, but they will not include changes for the old volume GUID that no longer exists.
NOTE New volumes are excluded by default. You will need to manually include a volume via the Volume Level Backup Control option to back it up.
Resolution
Navigate to the Datto appliance GUI and select the Protect tab.
Select Configure Agent Settings for the affected agent.
In the left navigation bar, select Volume Level Backup Control.
Find the missing duplicate volume and select the trash can icon on the far right of the missing volume to delete the volume's live dataset.
NOTE Deleting the live dataset for a volume will not remove the contents of previous backups, but will prevent it from being referenced by future backups. This is recommended when excluding a previously included volume to preserve space going forward, or could be used to take a full backup of a single volume.
Exclude the missing volume, using the check box under the column Exclude Volume.
Select Refresh Drives.
Re-include the restored volume that was previously excluded.
Select Refresh Drives.
If you get an error stating "Cannot exclude volume" when trying to exclude the missing volume, you may need to exclude, then include the active replica of the "missing volume" instead.
Excluding a volume will not remove the volume's live dataset. If, after an Image Export, you see a large discrepancy between your current protected storage size and the amount of local used space on the Datto device, contact Datto Technical Support for assistance in evaluating the issue.