Datto Appliance Cannot Update Due to Device Activity
Issue
Datto devices can become out of date due to certain activity on the device preventing the update from taking place.
Environment
- Datto SIRIS
- Datto ALTO
- Datto NAS
Cause
Your Datto appliance has not updated for 90 days following a release to its subscribed channel.
During a scheduled update window, the Datto appliance detected one or more of the following conditions, and the condition did not resolve within the allowed update period:
- A running local or hybrid virtualization
- User activity on an iSCSI share hosted on the device
- Active NFS connections to NAS shares hosted on the device
- An in-progress backup or offsite synchronization
- An active device migration
- A bootable USB device, such as a RoundTrip drive, is connected to the appliance
- An invalid networking configuration which could cause the appliance to lose network connectivity on reboot exists on the device
- The Datto appliance cannot reach the image server
- One or more system processes on the appliance are hung
IMPORTANT Devices 90 days out-of-date will ignore these system checks and attempt to update automatically. Datto strongly recommends proactively updating your device to prevent this scenario.
Resolution
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If you are not in a disaster recovery scenario, remove any local or hybrid virtualizations present on the appliance.
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Close any active iSCSI or NFS connections to the device by having your end-users disconnect from the Datto device's network shares.
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Ensure that all backups and offsite synchronization activities have completed and that the device's backup and offsite sync schedules do not conflict with its scheduled update window.
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If a device migration is active on the appliance, it must complete before updates can be applied.
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Check the Datto appliance for bootable USB media, such as a RoundTrip drive. Disconnect any hardware found.
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Review your appliance's Network Configuration page to ensure that no incompatible configurations exist, such as disabled NICs or invalid IP addresses, which could cause the device to lose network connectivity on its next reboot. Ensure that the Datto appliance's network environment meets the Networking & Bandwidth Requirements.
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Reboot the Datto appliance to clear any hung processes.
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After performing all necessary troubleshooting steps, click Upgrade now in your Datto device's GUI to install the available device updates.
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If you have attempted all of the steps in this article, and are still unable to update your appliance, contact Datto Technical Support for assistance.